[Grml] Speakup and non-ascii characters

Hermann meinelisten at onlinehome.de
Mon May 25 14:53:36 CEST 2009

On 25.05.2009 at 14:34:45 Michael Whapples <mwhapples at aim.com> wrote:

> I tried some stuff on my system. Here is what I found.
> When I edited the copy of the table I used nano for my editor and it 
> added an extra blank line and so when I tried to copy the table into 
> /sys/module/speakup/parameters/characters it didn't go in because of the 
> extra line. You should have a single new line character following the 
> last entry in the table (nano made it two new lines). However I didn't 
> get any error message with this copying, it just didn't go in. When I 
> corrected the table and then tried to copy it, everything worked fine.
OK, that was it. Reediting the file with emacs did the trick.
Note: You can change the config file of nano, so that this additional
line isn't put in. I'll do so.
One question about /etc/rc.local: Where to put the cp command? Before or
after that "exit 0" line?

More information about the Grml mailing list