[Grml] network boot with nfs4 root

Michael Prokop mika at grml.org
Mon Jan 21 19:59:58 CET 2013

* Joerg Dorchain [Sat Jan 19, 2013 at 01:38:54AM +0100]:

> I tried to setup a boot server with pxe. I followed loosely the
> wiki http://wiki.grml.org/doku.php?id=terminalserver for that.
> So far all went fine, except mounting the root over nfs4.

> My nfs server is version4 only, and from packet logs I see that
> grml tries nfs version3 only over and over.

> Is this a bugs or is there some trick for get it to work with
> nfs4?

AFAIK klibc still doesn't support nfs v4:


I'm not sure whether there are reasonable ways to work around klibc,
trying dracut instead of initramfs-tools might be a good start as
booting from nfsv4 works there (though I've no idea yet what needs
to get adjusted so it works for our live boot mode). I'm definitely
interested to see nfs4 working for netboot out-of-the-box on Grml
too, so if there's something where we could help please let us know.

> Also, as I am using the grml96 iso image via a loopback mount, I
> would greatly appreciate if I could use the bootmenu for isolinux
> also for pxelinux. To me it seems it is mainly a matter of
> pathnames (and maybe symlinks) to get it to work with  a statement like

> LABEL grml-from-iso
>    CONFIG <iso-root>/boot/isolinux/<common.cfg>
>    APPEND <<iso-root>

> from pxelinux.cfg

Hm, a symlink pxelinux.cfg pointing to {isolinux,syslinux}.cfg isn't
enough, right? Any chance you could provide a working pxelinux.cfg
so we could work on an according template for grml-live (see
https://github.com/grml/grml-live/tree/master/templates/boot/isolinux )

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
URL: <http://ml.grml.org/pipermail/grml/attachments/20130121/f4691b7a/attachment.pgp>

More information about the Grml mailing list