[Grml] Trying to boot grml ISO image with grml-rescueboot fails

Frédéric Boiteux fboiteux at calistel.com
Fri Feb 18 08:24:20 CET 2011


  I don't know GRML yet, but I've heard about it in Mikas' blog
and liked to try it, so I installed grml-rescueboot (0.2.0 version)
debian package from http://deb.grml.org/ and installed it on my Debian
Squeeze system, along with the grml64-medium_2010.12.iso image
in /boot/grml directory. I then tried to boot it through the Grub2's
menu entry, but it didn't work (using menu, we don't see any error
message). I then try to launch every command of the menu entry in
Grub2's command line, and it fails in the line :

 loopback loop "/boot/grml/grml-medium_2010.12.iso"

telling it doesn't find this file. I think the 'root' setting is
missing, and as I have before Grml a grub menu entry to boot a Windows
partition, the last root setting isn't the right one.

I've manually set 'root' and then I finally got a new menu, from GRML,
and then I tried the 'forensic mode', as I didn't want GRML using my
swap partition (I had an hibernated system there), but the debian-live
system didn't work. I don't have any clue here as the 'debug' variable
wasn't set (and so /live.log was empty), but I'll retry this when I
have some spare time).

   Hope it can help,

More information about the Grml mailing list