[Grml] pxe-boot-problems

Martin Schulte schulte-martin at web.de
Mon Mar 8 22:01:51 CET 2010


i'm using grml the first time, and i run in some problems. I followed 
this guide http://wiki.grml.org/doku.php?id=terminalserver to boot grml 
via pxe. My default config-file looks like this:
LABEL grml
KERNEL linux26
APPEND root=/dev/nfs rw nfsroot=main:/nfs/grml boot=live lang=us nomce 
quiet apm=power-off nodhcp noprompt noeject initrd=minirt26.gz vga=791
I copied the linux26 and the minirt26.gz file to my tftpboot-directory. 
PXE-booting worked before.
I mounted the grml-medium_2009.10.iso using 'mount -o loop' to 
/nfs/grml. This path (/nfs) is entered in the /etc/exports and works fine.

While booting, i get the message:
Could not find kernel image: linux
 If you look above in my default the kernel is set this way: KERNEL linux26

so, i first don't unterstand the sense of this message, because the 
kernel is named: linux26
Second, after renaming linux26 into linux, this message don't occurs, 
but the system is going down, soon.

Someone who knows the resons?

Thanks, Martin

More information about the Grml mailing list