[Grml] problems with speech, both 64 and 32 bit versions.

Doug Smith dougsmith1 at charter.net
Sun Oct 5 04:07:20 CEST 2008

Ok, I hate to do this, but here goes.  The other night, I downloaded
both the new latest devel releases and burned them, hoping to switch
this machine over to text-based.  Here's what happened with the speech
in both versions.  

First of all, this machine's a 64-bit one, so I tried the 64-bit version
of the latest devel release.  

boot the computer with the disk in it.  I kept them separate so that I
would know that the one I was starting out with was the 64-bit

grml swspeak

when the disk stops spinning for the first time.  The boot procesSmith,
you might just have it.  

Well, I did get it, but what I got was not what I wanted.  This was the
flite Kal voice coming on with the simple, but rather non-informative

Fatal Error Setting Up Software Speakup.

Well, blast it.  I might not get to switch my system over that night.  I
would have enjoyed that couple of hours when it comes to configuring my
system, but not this time.  

Well, after a little longer, the flite program spoke again.  Finished

What is the setup that allows the flite program to speak even if the
speakup fails?  Well, since it spoke again, I thought I would try it
anyway and see what I get.  


Sorry, software synthesizer not available, did you boot with swspeak

Well, of course, I did, but the system is unaware of it.  Funny, but
I'll try it out.  


That gets part of the trick done, but not all.  Espeak simply echoes all
of my commands, so no results from them, except to know that something
did, indeed, go horribly wrong.  Well, I don't believe this.  

kill the espeak process to keep it from blocking my terminal.

Now, I know that there are actually two software synthesizers, if not
more, available, so don't give me that meaningless message.  

dmesg | espeak

This was the only way I could think of to attempt to determine what was
going wrong.  All I heard was information about configuring and
activating every component from the microprocessors to the disk drive
and the usb ports, but nothing about an abnormality with speakup.  

Well, now, 32-bit version on a 64-bit machine, but I'm not going to my
lady friend's room and disturb her to borrow her machine, and, besides,
this would change another variable in my experiment and I just wanted to
know what was happening here.  

boot the computer with the disk in it.  I use the other one this time.  

grml swspeak

Well, the first boot attempt falls flat on its face as the message about
ossaudio failing to open an output device.  Why is speakup or something
still trying to use oss?  ALSA, I thought, had become the standard a few
years ago.  

The second boot came up talking.  Great!!! However, I'm not going to run
32-bit stuff on here even though I know it will work, at least in

Now, we've got speech, and it's working reasonably well.  Now, fire up
elinks and head for a few favorite web sites.  

It works reasonably well, and I am beginning to ponder the possibilities
of using this stuff till the 64-bit one works.  Then it happens.
Instead of going to another web site, we crash land and explode into
flames in glitchville.  

Speech crashes, and nothing but a reboot will remedy the problem.  It
worked for a couple of minutes, and I am not sure what kinds of
diagnostics might determine the nature of the problem.  Anyway, I'm on
this thing without speech, and that can be potentially dangerous,
especially for the already-installed file system, which I'm using right
now to write this.  

Well, this is the best I can do at present for a but report, since it is
the programming I definitely need that caused the problem.  I hope this
helps in some way and this can be fixed in the 64 and 32 bit versions in
the next devel releases or in the rc versions.  

Hope this helps. 

Doug Smith

More information about the Grml mailing list