[Grml] Netboot package for grml64 2008_11

Markus Wigge mwigge at marcant.net
Wed Nov 26 19:33:34 CET 2008

Hi list,

> % grml-tips netboot
> Create netboot package for grml-terminalserver:
> # sh /usr/share/doc/grml-terminalserver/examples/create-netboot
> We use that script for creating the official netboot packages as
> well and we will provide official netboot packages as soon as the
> stable release is on the way (which is expected to happen with the
> next few days).
fine I thought.
First of all I extracted a grml-small squashfs.
Then I chrooted to the squashfs-root created by unsquashfs to "apt-get
install grml-terminalserver".

Now executing the above mentioned script resulted in a minor error
because "make" was not installed as a dependancy.
Further on it tried to setup the chroot environment as the
terminalserver which I never intended ...

Finally I got a grml_netboot_package_grml-small_2008.11-rc1.tar.bz2
containing nothing useful:

Later I figured out a call "grml-terminalserver-config initrd" which
sounded promising but which tried to loopback mount a CPIO archive ?!
> + eval 'mount -o loop=/dev/loop3 /tmp/terminalserver_initrd.yzNoiv/minirt26 /etc/grml/terminalserver/mini-root.orig '
> ++ mount -o loop=/dev/loop3 /tmp/terminalserver_initrd.yzNoiv/minirt26 /etc/grml/terminalserver/mini-root.orig
> mount: you must specify the filesystem type

As far as I could see the CPIO archive was copied from /cdrom which
contained the mounted ISO (loopback from outside the chroot).

Well finally I did not succeed in building an apropriate initrd to use
for my existing PXE setup.

Now what did I do wrong? Or did I completely misunderstand the usage of
the provided scripts?

Thanks in advance,

More information about the Grml mailing list