[Grml] /cdrom/scripts not working

Michael Prokop mika at grml.org
Mon Feb 18 23:30:11 CET 2008

* Jon <iroquoi at gmail.com> [20080218 23:18]:
> On Mon, Feb 18, 2008 at 10:53:00PM +0100, Michael Prokop wrote:
> > * Jon <iroquoi at gmail.com> [20080218 22:20]:

> > >   boot:
> > >   Could not find kernel image: /boot/grmlmedium/linux26

> > What method did you use for preparing the usb device?
> > Manually or using grml2usb?
> > Does the directory boot/grmlmedium on your usb device exist?

> I prepared it manually but boot/grmlmedium/linux26 exists.


> > JFYI: The "Prepare system" instructions on
> > http://wiki.grml.org/doku.php?id=usb aren't up2date in those hours
> > because we had to rework the directory layout on grml due to a
> > problem with syslinux. grml2usb should work though, if not it's a
> > bug. :)

> Well, I formatted the partition and tried grml2usb but still get the 
> same error. :-)

Ok sorry, looks like syslinux has a problem with the /boot/...

I've to check this out on my own (I'm just running out of time). If
you need a fix in the meanwhile: just move linux26 and initrd.gz
from boot/grmlmedium/ to the root directory of your usb stick and
replace the /boot/grmlmedium/ occurences inside your syslinux.cfg -
then it should work for you.

 http://grml.org/            # Linux for texttool-users and sysadmins
 http://wiki.grml.org/       # share your knowledge
 http://grml.supersized.org/ # the grml development weblog
 #grml @ irc.freenode.org    # meet us on irc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://ml.grml.org/pipermail/grml/attachments/20080218/1548280e/attachment-0004.pgp>

More information about the Grml mailing list