[Grml] [Grml 1.0] cannot boot anymore after upgrade

Michael Prokop mika at grml.org
Wed Oct 3 07:45:38 CEST 2007

* Ja Bu <jb_int at care2.com> [20071003 01:53]:

> I am quite new to GRML (and Debian/Knoppix based distributions). 
> However, I have some experience with other Linux distris. 

> So recently I got a virtual appliance with Grml installed already. 
> One of the first things was to use apt-get (first attempt) and
> aptitude (second attempt) to upgrade all upgradable packages. 
> The results was the same: 
> I could not boot anymore. The only thing that appears is 'GRUB'
> without any further error message. 

> I have spent two days already to figure out what happens. I have 
> seen reports about similar errors when updating ubuntu versions. 
> The reason was a switch from hdX to sdX (and a mismatch of the UUIDs). 

> I checked all that: UUIDs are fine. And even with the device names the 
> symptoms are the same. 

> I then tried to reinstall GRUB. The installation process yielded no 
> errors (the menu.lst and the device map are fine). Nevertheless
> I get the same error :-(


> Then I thought: Maybe it's only a GRUB problem and tried LILO. With 
> lilo I get some more information, but also the boot process stops very 
> early. I get error messages about some modules that cannot be loaded. 
> (I currently have no access and, thus, cannot type the exact error message here.)

The last 1-2 lines of the output would be interesting.

> I am wondering whether this has something to do with the 
> linux-kernel-header-grml package which apt-get/aptitude were keen to 
> remove?

No, linux-kernel-header-grml does not contain any files used for
booting stuff.

> I am also wondering: I surely am not the only one who ever upgraded 
> a GRML 1.0 system, or? Did noone ever encountered a similar problem? 

> I appreciate every hint which might bring me closer to a solution
> of this most annoying problem. 

Can you please provide the output of:

dpkg --list mdadm lvm2 initramfs-tools lilo grub udev

of the system? (Just boot grml live and chroot into your system)

If you change the root=UUID=... line within grub/lilo to something
like root=/dev/... (where the later device corresponds with your
root partition) - does it boot then?

JFYI: I'll try to reproduce the problem on my own here, so
you definitely won't be lost with a not-bootable system.

 http://grml.org/            # Linux for texttool-users and sysadmins
 http://wiki.grml.org/       # share your knowledge
 http://grml.supersized.org/ # the grml development weblog
 #grml @ irc.freenode.org    # meet us on irc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://ml.grml.org/pipermail/grml/attachments/20071003/87ddb352/attachment-0004.pgp>

More information about the Grml mailing list