[Grml] [Grml 1.0] cannot boot anymore after upgrade

Ja Bu jb_int at care2.com
Wed Oct 3 01:38:21 CEST 2007

Hi all, 

I am quite new to GRML (and Debian/Knoppix based distributions). 
However, I have some experience with other Linux distris. 

So recently I got a virtual appliance with Grml installed already. 
One of the first things was to use apt-get (first attempt) and
aptitude (second attempt) to upgrade all upgradable packages. 
The results was the same: 
I could not boot anymore. The only thing that appears is 'GRUB'
without any further error message. 

I have spent two days already to figure out what happens. I have 
seen reports about similar errors when updating ubuntu versions. 
The reason was a switch from hdX to sdX (and a mismatch of the UUIDs). 

I checked all that: UUIDs are fine. And even with the device names the 
symptoms are the same. 

I then tried to reinstall GRUB. The installation process yielded no 
errors (the menu.lst and the device map are fine). Nevertheless
I get the same error :-(

Then I thought: Maybe it's only a GRUB problem and tried LILO. With 
lilo I get some more information, but also the boot process stops very 
early. I get error messages about some modules that cannot be loaded. 
(I currently have no access and, thus, cannot type the exact error message here.)

I am wondering whether this has something to do with the 
linux-kernel-header-grml package which apt-get/aptitude were keen to 

I am also wondering: I surely am not the only one who ever upgraded 
a GRML 1.0 system, or? Did noone ever encountered a similar problem? 

I appreciate every hint which might bring me closer to a solution
of this most annoying problem. 

Thanks in advance, 


http://toolbar.Care2.com  Make your computer carbon-neutral (free).

http://www.Care2.com  Green Living, Human Rights and more - 7 million members! 

More information about the Grml mailing list