[Grml] Re: Installing X in Grml-Small0.4 HD install

Michael Prokop mika at grml.org
Sat Aug 11 20:22:28 CEST 2007

* - Tong - <mlist4suntong at yahoo.com> [20070811 15:18]:
> On Fri, 10 Aug 2007 05:57:28 +0200, Michael Prokop wrote:

> >> Q1: How can I overcome the "acpid: invoke-rc.d: initscript acpid, action
> >> "start" failed" problem?

> > Try:

> > chmod -x /etc/init.d/acpid
> > apt-get install acpid

> No, that gives me the same error message as well. In fact, I found that
> the /etc/init.d/acpid already has the a-x mode.

a-x? The script should *not* have any execution bits set so the
'if [ -x "/etc/init.d/acpid" ]; then' from
/var/lib/dpkg/info/acpid.p* does not match.

Are you really sure you executed my lines above?
Please provide output of:

ls -la /etc/init.d/acpid
apt-get install acpid

> While trying to find
> what's wrong, I've tried the following but all failed:

>  invoke-rc.d acpid start
>  /etc/init.d/acpid start

> Tracing into /etc/init.d/acpid, I noticed that it is this code that
> returns error:

>  start-stop-daemon --start --quiet --exec /usr/sbin/acpid -- -c \
>  /etc/acpi/events -s /var/run/acpid.socket

For sure, cause your system (VMware) wants to prevent you from using
something that doesn't make any sense. ;)

> Any idea? 
> Oh, forgot to mention, I'm testing within vmware. 

Forget powermanagement inside VMware. :)

 http://grml.org/            # Linux for texttool-users and sysadmins
 http://wiki.grml.org/       # share your knowledge
 http://grml.supersized.org/ # the grml development weblog
 #grml @ irc.freenode.org    # meet us on irc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://ml.grml.org/pipermail/grml/attachments/20070811/32edfbe3/attachment-0004.pgp>

More information about the Grml mailing list