[Grml] df: `/dev/.static/dev': Permission denied

Michael Prokop mika at grml.org
Sat Oct 7 15:18:05 CEST 2006

Just noticed that I forgot to inform you about the solved issue:

* Michael Prokop <mika at grml.org> [20060826 11:15]:
> * T <mlist4suntong at yahoo.com> [20060824 05:15]:

> > Whenever I run df, I get `/dev/.static/dev': Permission denied:
> > what might be the problem? the cure?

> > I'm using grml 0.7 hd installation. 

> I'm aware of this problem but not yet sure who is responsible for
> it. Looks like a udev problem.

> If you are running the 'df' as user root you won't notice the
> problem. To fix the issue for normal users as well just manually
> invoke 'umount /dev/.static/dev'.

> The issue is on my todolist and I'll provide a fix soon.

Make sure you have a recent version of the initscripts, sysvinit and
grml-etc packages. Then make sure /etc/mtab is *not* a symlink to
/proc/mounts anymore:

# rm /etc/mtab ; cp /proc/mounts /etc/mtab

Now the "/dev/.static/dev: Permission denied" shouldn't be present
anymore (at least on next reboot).

HTH && regards,
You like grml?  Help us!      http://grml.org/donations/
Already on the grml-user-map? http://www.frappr.com/grmlusers
The Grml Planet               http://planet.grml.org/
Grml Solutions                http://solutions.grml.org/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://ml.grml.org/pipermail/grml/attachments/20061007/0dbae364/attachment-0003.pgp>

More information about the Grml mailing list