[Grml] grml boot test report. :-)

Michael Prokop mika at grml.org
Sun Jun 25 22:25:38 CEST 2006

* s. keeling <keeling at spots.ab.ca> [20060625 19:15]:

> grml's lovely, or what I saw of it is.  Nothing I did would go anywhere
> near a framebuffer console. "grml-info" replies:

>    Could not initialize graphics driver fb:
>    Cannot open /dev/fb0.

> "fbset 1024x768-70" replies:

>    open /dev/fb0: no such file or directory

Well, switching resolution on the fly won't work with vesafb.

> I tried boot options grml lapic vga=791
>                                 vga=normal
>                                 vga=ask
>                                 fb1024x768

> and no joy.  Surely I'll find a simple answer in the FAQ, I know.

So you just don't get a framebuffer at all?

> Other things to note include:

>    - on the F9 boot prompt page:

>        "Notice: you this bootoption with care!"

>      s/you/use/

Thanks, has been fixed in current develrelease already. :)

>    - dmesg reports:

>        VFS: can't find an ext2 filesystem on /dev/hda

>      which is a little odd as I'm using it to type this.  :-)  After
>      fiddling with grml a bit, I also tried the new
>      gparted-livecd-0.2.5-1.iso I downloaded recently.  It found all
>      my ptns on both disks.

What does 'cat /proc/partitions' say?

* s. keeling <keeling at spots.ab.ca> [20060625 21:10]:

> > I tried boot options grml lapic vga=791
> >                                 vga=normal
> >                                 vga=ask
> >                                 fb1024x768

> Ah.  I used vga=normal, then "grml-x -mode '1024x768' -module i810
> fluxbox" and all was well.  It's gorgeous!  :-)  Questions &
> suggestions (this is all while running from CD, btw):


>   - How do I get a left-handed mouse?  'xmodmap -e "pointer = 3 2 1 4
>     5 6 7 8 9"' works but confuses the heck out of already running
>     apps (I've a 3 button ps2 mouse).

Does it work for you if you add it to ~/.xinitrc before running

>   - XConsole is one annoying app.  Running it from X you get "Couldn't
>     open xconsole".  I usually do "su" (no dash) then run it from a
>     root command line, then exit.  This (su, no dash) uses the user's
>     ~/.Xauthority.

You need to have read-permissions for /dev/xconsole.

>     Doing this in grml, trying to exit out of the root
>     login, I get "You have running jobs.", and exit fails.  Drat.  Do
>     I have to use nohup?  Or will one of your brilliant zsh tricks
>     (RUNASROOT) solve this?

Just run 'exit' once more and you won't get the "You have running
jobs" a second time. ;)

>   - Dillo fires up with the grml start page when logging into X.
>     Re-running Dillo starts up with a Dillo start page.  You should
>     change that to go to the grml start page.

Well, people who already know what's grml probably don't need the
grml start page anymore so the default is pretty ok IMO. :)

>   - I forgot to check.  What's i810rotate do?

% apropos i810rotate
i810rotate (1)       - toggle the video output on i810 hardware using i810switch(1)

>   - I'm sorry, but I'm going to have to steal your .zshrc  :-)  Tres
>     cool! 

Feel free to do so. :)

You like grml?  Help us!      http://grml.org/donations/
Already on the grml-user-map? http://www.frappr.com/grmlusers
Grml Solutions                http://solutions.grml.org/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://ml.grml.org/pipermail/grml/attachments/20060625/227e36fe/attachment-0003.pgp>

More information about the Grml mailing list