[Grml] grml-x glitches

Michael Prokop mika at grml.org
Sun Feb 5 19:25:02 CET 2006

* Mark <or2uvma02 at sneakemail.com> [20060204 01:15]:

> I tested the FAQ advice about grml-x and nvidia.  The simple command was

>    grml-x -nostart -module nvidia gdm

> If I run as root, I get a strong warning message that grml-x does not
> support root.  (P.S. Why not?)

Running X as user root is nothing you should use. Therefore the
warning message and the advice to use the '-nostart' option if you
want to create /etc/X11/xorg.conf.

To avoid confusion as far as possible, grml2hd even checks for
existence of /etc/X11/xorg.conf and creates one on request (default
== yes).

> If I run as a non-root user, I get error messages about the user lacking
> privileges to run certain binaries.

Sure, as you have to write files you are not allowed to modify
without root-permissions. On live-cd that's not a problem at all,
but on hd-install it's deactivated for security reasons.

You like grml?  Help us!      http://grml.org/donations/
Already on the grml-user-map? http://www.frappr.com/grmlusers
Grml Solutions                http://solutions.grml.org/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://ml.grml.org/pipermail/grml/attachments/20060205/20052879/attachment-0003.pgp>

More information about the Grml mailing list