[Grml] Problem with speakup on grml 2009.10

Michael Whapples mwhapples at aim.com
Wed Dec 23 03:49:01 CET 2009

I have just written the grml 2009.10 CD but I notice that for some 
reason when I try and boot it with options for speakup with software 
speech output (either the swspeak option or speakup.synth=soft option) 
it isn't recognised. The strange thing is it seems to be that when I 
give an option to enable software speech output with other options then 
grml doesn't seem to recognise the other options either.

Here is what I have done to try and check what happens and also to try 
and confirm it isn't me:
* When this first happened I thought may be it was me doing something 
wrong (as I get no output at the boot screen) so I tried again but still 
the same result.
* I have written it to another CD (at a slower speed as well) incase 
something has gone wrong with the CD or went wrong while writing it, 
still things don't work.
* When I give the other options on their own they work fine (the other 
options are either brltty or blind)
* I tried running swspeak once the booting finished and this started 
software speech output.
* I rebooted again specifying swspeak and blind at the boot prompt 
(still nothing, expected from previous attempts) I then checked 
/proc/cmdline and dmesg to try and find out what it says I gave at the 
command line, none of the options I gave were there.

I am now stuck as to why this is happening.

Also I notice (this is on my laptop) the keyboard layout by default is 
not anything like I have known in the past (I believe US keyboard layout 
is normally the default but this has things like shift+0 as =, what on 
the UK keyboard is / as -, the UK keyboard ? is ?, shift+7 gives /, and 
a number of symbols I don't even recognise appear on other keys).

Michael Whapples

More information about the Grml mailing list