[Grml] Wlan with rt61 and wpa

Andreas Gruber gruber_andreas at gmx.de
Sat Mar 8 03:23:06 CET 2008

Michael Prokop schrieb:
> * Andreas Gruber <gruber_andreas at gmx.de> [20080226 12:45]:
>> AFAIK, the RT2500 (and others of the RT2X-series) -Wlan-driver is
>> supportet since gml0.9 or earlier by a grml-package. Can You tell
>> me, if there's an package for the RT61-driver of Ralink in
>> grml1.1. At the moment, my notebook uses Debian etch with a
>> PCMCIA-Wlan-card with RT61 - it works, but it was a little bit
>> difficult to manage it. I would be great, to install grml on these
>> notebook.
> rt2x00-modules-2.6.23-grml isn't included within grml 1.1 because we
> had too many conflicts with rt2400-modules-2.6.23-grml and
> rt2500-modules-2.6.23-grml. I'd like to investigate on that in the
> next few days/weeks with people having the appropriate hardware
> (please let me know if you are such a person :)).
> I've uploaded rt2x00-modules-2.6.23-grml for you to grml-testing
> pool which provides the module:
>   /lib/modules/2.6.23-grml/kernel/drivers/net/wireless/rt61pci.ko
> So just grab
> http://deb.grml.org/pool/main/r/rt2x00/rt2x00-modules-2.6.23-grml_2.0.12%2bgit20071103-3%2bgrml.06_i386.deb 
> and give it a try. Please let me know whether it works for you.
>> ...and not to forget:
>> grml1.1 - great work - congratulations to the team around Mika!
> Thanks :)
> regards,
> -mika-
> ------------------------------------------------------------------------
> _______________________________________________
> Grml mailing list - Grml at mur.at
> http://lists.mur.at/mailman/listinfo/grml
> join #grml on irc.freenode.org
> grml-devel-blog: http://grml.supersized.org/
Hi Mika & friends!

I've asked a few days ago for rt61-wlan-driver-support in grml. Now I've 
tried the package provided - and the module seems to work! I'm afraid, 
still I couldn't manage to get my wlan to work. I have to use WPA-PSK.

This is, what I've done:
- wget your deb
- dpkg -i the deb
- modprobe rt61pci
- rename the /etc/wlan/wlancfg-DEFAULT in wlancfg-myssid (with my ssid)
- setting dot11ExcludeUnencrypted to false in the wlan-cfg-myssid 
because of not using wep
- setting SSID_wlan0="myssid" in /etc/wlan/wlan.conf
- typing
  psk="mypassword"} (with my phrase)
 in my /etc/wpa_supplicant/wpa_supplicant.conf
- adding
  auto wlan0
  iface wlan0 inet dhcp (dhcp is running in my network)
  wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
  to my /etc/network/interfaces.
Now, iwconfig wlan0 shows my essid and an encryption-key, but I'm not 
able to ping. Strange is, that after typing
wpa_supplicant -i wlan0 -D wext -c 
/etc/wpa_supplicant/wpa_supplicant.conf -d, the iwconfig wlan0 command 
shows Encryption key:off. Perhaps, here tht problem is to find...?

Do you, Mika, or someone else have an idea, why it still doesn't work?
Thanks for all the help you gave and give!

Dipl.-Ing.(FH) Andreas Gruber
Isaak-Loewi-Straße 21
90763 Fürth

More information about the Grml mailing list