[Grml] grml 1.0 grml2hd issues

Lars Schimmer l.schimmer at cgv.tugraz.at
Sun Jun 24 12:25:21 CEST 2007

Hash: SHA1

Michael Gebetsroither wrote:
> Quoting Lars Schimmer <l.schimmer at cgv.tugraz.at>:
>> I let it run, added root pwd, username,userpwd, deleted the apache
>> server, added hal, choosed grub in mbr and waited til it was done and
>> rebooted.
>> After reboot, it couldn´t mount /root, because "device not found or
>> busy".
>> I tried it with UUID and with /dev/sda3 in grub....
> We've debugged the problem together and found the evil root cause!
> It was dmraid!
> Dmraid starts an intel fakeraid because there was a valied intel
> software raid metadata chunk on the disk. We suppose this comes from
> some stresstesting with Windows from the vendor.
> Once found this could easily be corrected.
> dmraid -r /dev/sda -E
> dmraid -r /dev/sdb -E
> The command aborts and prints out a backtrace but netherless it removed
> the metadata chunk from the disk successfully.
> But after this metadata removeal grub won't boot the system anymore,
> just reinstall it.
> mount /dev/sda3 /mnt/sda3
> grub-install --root-directory /mnt/sda3 /dev/sda
> And everything worked as expected.

A BIG thanks to the helping people :-)

> cu,
> Michael

Lars Schimmer
- --
- -------------------------------------------------------------
TU Graz, Institut für ComputerGraphik & WissensVisualisierung
Tel: +43 316 873-5405       E-Mail: l.schimmer at cgv.tugraz.at
Fax: +43 316 873-5402       PGP-Key-ID: 0x4A9B1723
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the Grml mailing list